It is currently Wed Jul 09, 2014 11:09 pm
Change font size
SpaForums.Com Spa & Hot Tub Service, Repair and Help

Electric Heater Problems

Jacuzzi not heating

Jacuzzi not heating

Postby Aroark » Sun Apr 03, 2011 6:39 pm

Jacuzzi/whirlpoool echo/essence z140/340 5 man spa(probably early 1990's??) model H850000
240 volt system
Balboa 52222 controller
5.5 kw flow thru heater element
Two water pumps

It hadn't run in 2 years. Filled it up. Discovered leaks, pumps worked. Drained, fixed leaks.
Filled it up. Everything seemed to work except it never heated up. Drained, removed heater element. It was rusted through at terminals.
New terminals and element, filled it back up... Still no heat.
My simple diagnoses thus far:
Heating light is on - good
Everything about the module seems fine.
Resistance in the element is 12 ohms.
Voltage across both element terminals 230 volts.
Plenty of flow in the tube, both pumps operating normally.

How can I have voltage to the heater and it doesn't heat.?
What next.?

Thanks for looking.
Aaron
Aroark
 
Posts: 1
Joined: Sun Apr 03, 2011 5:56 pm

Return to Electric Heater Problems

Who is online

Users browsing this forum: No registered users and 1 guest

Search

User Control Panel